IOS Host Setup

Initial configuration of the router

There is a configuration procedure for the different cisco architectures in the following guide:

https://communities.cisco.com/docs/DOC-60578

Network Configuration (startup-config)

Use the below example for your own custom configuration.

The hostname you set in the IOS environment will be set to the OS part immediately.

The most important lines are commented.

  1. Open the terminal and enter enable
  2. Enter the privileged mode with configure terminal
  3. Copy belows config (change necessary ips) and paste it, the device will slowly process it
  4. If no errors, save it by entering copy running-config startup-config
!
enable secret 7 JDEkUXZKMlRuL1kkSjMvTVlldmtWYU1hTlpJakNxSnpOMA==
!
logging buffered errors
!
ip name-server 8.8.8.8
ip name-server 8.8.4.4
!
interface Vlan 1
 ip address 192.168.97.133 255.255.255.0
 ip nat inside
 exit
!
! Set VLAN1 for the GE 0/1 for basic ethernet access
interface GigabitEthernet 0/1
 switchport mode access
 switchport access vlan 1
 no shutdown
 exit
!
! Only required when used with 3G SIM cards
chat-script gsm "" "ATDT*99*1#" TIMEOUT 30 "CONNECT"
!
interface cellular 0
 ip address negotiated
 ip nat outside
 dialer string gsm
 ppp chap hostname t-mobile
 ppp chap password tm
 exit
!
controller cellular 0
 cellular mode 1
 gsm sim profile 1
 exit
!
! Set the username to allow SSH login to the IOS terminal
aaa authentication login default local
username admin password admin
!
ntp server ip 0.de.pool.ntp.org
ntp server ip 1.de.pool.ntp.org
ntp server ip 2.de.pool.ntp.org
ntp server ip 3.de.pool.ntp.org
!
clock timezone Europe/Berlin
!
hostname Cisco-Testlab01
! Activate the nat. Will only be used when the 3G is used as WAN
ip nat inside source 192.168.97.0 255.255.255.0 cellular 0 overload
! Set the default router of the local subnet
ip route 0.0.0.0 0.0.0.0 vlan 1 192.168.97.1
! If 3G us used as WAN replace the last line for ip route 0.0.0.0 0.0.0.0 cellular 0 
crypto key generate rsa

Generating a RSA Key

The first time the router is configured a RSA key has to be generated to be able to use the SSH:

Router (config)#crypto key generate rsa